Паскаль авс составить программу, которая создает массив случайных чисел размером (n x m), выводит его на экран и вычисляет произведение ненулевых элементов массива.
Program asd; Const n=5; m=4; Var i,j,p:integer; A:array[1..n,1..m] of integer; BEGIN For i:=1 to n do begin For j:=1 to m do begin A[i,j]:=Random(10); Write(A[i,j]:3); end; Writeln; end; P:=1; For i:=1 to n do For j:=1 to m do begin if A[i,j]<>0 then p:=p*A[i,j]; end; Writeln('Произведение ненулевых элементов массива: ',p); END.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку