Kola2004kola
14.06.2020 04:25

15 напишите программу, которая удаляет из строки n символов с конца.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
olaved1
14.07.2020 20:57
Uses crt;
var s: string;
n,q :integer;
begin
while n=0 do begin
writeln ('Введите строку ');
readln (s);
n:=length(s);
clrscr;
end;
writeln('сколько символов нужно удалить из ',s,' ?');
read (q);
if q>n
then begin writeln ('символов для удаления больше, чем существует');     
s:='';  end
else   
delete (s,((n+1)-q),q+1); 
write (s); 
 end.

P.s. Программа написана на языке Pascal ABC.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота