diana2005n
17.07.2020 18:58

Написать программу в паскале. : на плоскости даны 2 точки а (х1; у2) и в (х2; у2), определить какая из них находится дальше от начала координат. я поняла, что нужно найти их длины (формулы я знаю), а правильно написать программу не могу

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
tibefp33org
25.05.2020 17:22

program prog;
var x1,x2,y1,y2,i,b:integer;
begin;
writeln('Введите 4 точки: x1, y1; x2, y2');
readln(x1,y1,x2,y2);
i:=abs(x1+y1);
b:=abs(x2+y2);
if i=b then writeln('Координаты находятся на одной точке') else begin
if i>b then writeln('Первая координата дальше') else writeln('Вторая координата дальше');
end;
end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота