Himimory
22.06.2020 05:22

Напишите программу для получения квадратной матрицы порядка n* n.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
HwaSa77816
14.07.2020 17:46

#include <iostream>

#include <ctime>

int N = NULL;

int main() {

srand((unsigned int)time(NULL));

std::cout << "Enter the N: ";

std::cin >> N;

int** matrix = new int*[N];

for (int i = 0; i < N; i++) {

 matrix[i] = new int[N];

}

for (int i = 0; i < N; i++) {

 for (int j = 0; j < N; j++) {

  matrix[i][j] = rand() % 100;

 }

}

for (int i = 0; i < N; i++) {

 for (int j = 0; j < N; j++) {

  std::cout << matrix[i][j] << " ";

 }

 std::cout << std::endl;

}

for (int i = 0; i < N; i++) {

 delete[] matrix[i];

}

delete[] matrix;

return 0;

}

Объяснение:

Данные матрицы — случайные числа

Память на массивы выделяется динамически, затем чистится.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота