Маджидия
20.08.2020 12:05

На языке программирования паскаль составить программу суммы нахождения суммы вводимых с клавиатуры положительных чисел . печать результата по вводу 0 ( используя цикл while т.е. предусловие ).

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Новичок301117
25.05.2020 17:16

var

 a, s: real; //a - вводимое с клавиатуры число, s - сумма чисел

 

begin

  a:= 1;  //Присваиваем начальное значение, чтобы цикл выполнился

  s:= 0;

  while a <> 0 do   

  begin

    writeln('Введите положительное число');

    readln(a);

    if a < 0 then

    begin

      writeln('Введено не положительное число. Повторите ввод заново');

      continue; {Если а - не положительное число, вводим число заново}

    end;

    s:= s + a;

  end;

  writeln('Сумма:  ', s);  //Выводим сумму

end.

  

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота