Katekate2001lol
31.01.2023 06:46

Составить программу в pascal. y=cosx+cos^2*x+cos^3*x++cos^k*x

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
nik102910
16.03.2022 08:04

type z=array of byte;

var i,a,b,s: integer;

digits: z;

f: text;

begin

assign(f,'input.txt');

reset(f);

read(f,a);

read(f,b);

close(f);

s:=a+b;

i:=0;

while(s>0) do

begin

setlength(digits,i+1);

digits[i]:=s mod 10;

s:=s div 10;

i:=i+1;

end;

for i:=0 to length(digits)-2 do

for b:=0 to length(digits)-i-2 do

if (digits[b] > digits[b+1]) then

begin

a:= digits[b];

digits[b] := digits[b+1];

digits[b+1] := a;

end;

if(digits[0]=0) then for i:=0 to length(digits)-1 do

if(digits[i]<>0) then

begin

digits[0]:=digits[i];

digits[i]:=0;

break;

end;

assign(f,'output.txt');

rewrite(f);

for i:=0 to length(digits)-1 do write(f,digits[i]);

close(f);

end.

0,0(0 оценок)
Ответ:
tim1110
30.08.2021 03:25
Что такое электронные образовательные ресурсы (ЭОР)?
Электронными образовательными ресурсами называют учебные материалы, для воспроизведения которых используются электронные устройства.
В самом общем случае к ЭОР относят учебные видеофильмы и звукозаписи, для воспроизведения которых достаточно бытового магнитофона или CD-плеера.
Наиболее современные и эффективные для образования ЭОР воспроизводятся на компьютере. Именно на таких ресурсах мы сосредоточим свое внимание.
Иногда, чтобы выделить данное подмножество ЭОР, их называют цифровыми образовательными ресурсами (ЦОР), подразумевая, что компьютер использует цифровые записи/воспроизведения. Однако аудио/видео компакт-диски (CD) также содержат записи в цифровых форматах, так что введение отдельного термина и аббревиатуры ЦОР не даёт заметных преимуществ. Поэтому, следуя межгосударственному стандарту ГОСТ 7.23-2001, лучше использовать общий термин «электронные» и аббревиатуру ЭОР.
Итак, здесь и далее мы рассматриваем электронные образовательные ресурсы, для воспроизведения которых требуется компьютер.
Чем отличаются ЭОР от учебников?
ЭОР бывают разные, и как раз по степени отличия от традиционных полиграфических учебников их очень удобно классифицировать.
• Самые простые ЭОР – текстографические. Они отличаются от книг в основном базой предъявления текстов и иллюстраций – материал представляется на экране компьютера, а не на бумаге. Хотя его очень легко распечатать, т.е. перенести на бумагу.
• ЭОР следующей группы тоже текстографические, но имеют существенные отличия в навигации по тексту.
Страницы книги мы читаем последовательно, осуществляя таким образом так называемую линейную навигацию. При этом достаточно часто в учебном тексте встречаются термины или ссылки на другой раздел того же текста. В таких случаях книга не очень удобна: нужно разыскивать пояснения где-то в другом месте, листая множество страниц.
В ЭОР это можно сделать гораздо комфортнее: указать незнакомый термин и тут же получить его определение в небольшом дополнительном окне, или мгновенно сменить содержимое экрана при указании так называемого ключевого слова (либо словосочетания). По существу ключевое словосочетание – аналог строки знакомого всем книжного оглавления, но строка эта не вынесена на отдельную страницу (оглавления), а внедрена в основной текст.
В данном случае навигация по тексту является нелинейной (вы просматриваете фрагменты текста в произвольном порядке, определяемом логической связностью и собственным желанием). Такой текстографический продукт называется гипертекстом.
• Третий уровень ЭОР – это ресурсы, целиком состоящие из визуального или звукового фрагмента. Формальные отличия от книги здесь очевидны: ни кино, ни анимация (мультфильм), ни звук для полиграфического издания невозможны.
Но, с другой стороны, стоит заметить, что такие ЭОР по существу не отличаются от аудио/видео продуктов, воспроизводимых на бытовом CD-плеере.
• Наиболее существенные, принципиальные отличия от книги имеются у так называемых мультимедиа ЭОР. Это самые мощные и интересные для образования продукты, и они заслуживают отдельного рассмотрения.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота