Язык pascal abc. напишите программу: дан двухмерный массив a[1..m,1..n]. написать программу построения одномерного массива b[1..m], элементы которого соответственно равны суммам элементов строк.
Const m=100; n=100; var a:array[1..m,1..n]of integer; b:array[1..m]of integer; i,j:integer; begin for i:=1 to m do for j:=1 to n do a[i,j]:=random(200)-100; for i:=1 to m do b[i]:=0; for i:=1 to m do for j:=1 to n do b[i]:=b[i]+a[i,j]; for i:=1 to m do write(b[i],' '); end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку