Airehon
27.07.2020 07:56

Составить программу для нахождения наименьшего общего кратного четырех натуральных чисел: по формуле нок(a,b)=(a*b)/нод(a*b) (определить процедуру, распознающую нод двух чисел)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
kisel2014
02.10.2020 03:15
uses crt;
var
a,b,c,d:longint; {нахождение НОД 2х чисел по Эвклиду}
function NOD(m,n:longint):longint;
begin
repeat i
f abs(m)>abs(n) then m:=m mod n
else n:=n mod m;
until (m=0) or (n=0);
NOD:=abs(m+n);
end;
begin clrscr;
write('a=');readln(a);
write('b=');
readln(b);
write('c=');
readln(c);
write('d=');
readln(d);
writeln;
writeln('NOD(a,b,c,d)=',NOD(NOD(a,b),NOD(c,d)));
readln
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота