timirshan
27.11.2020 19:07

Составить программу, которая проверяет правопис "жи", "ши" и выводит количество ошибок и исправленную строку

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Anna050503
13.07.2020 18:25
Var
a,count:longint;
s:string;
begin
writeln('введите строку');
count:=0;
read(s);
while pos('жы',s)>0 do 
begin
 inc(count);
 a:=pos('жы',s);
 delete(s,a,2);
 insert('жи',s,a)
end;
while pos('шы',s)>0 do 
begin
 inc(count);
 a:=pos('шы',s);
 delete(s,a,2);
 insert('ши',s,a)
end;
writeln(s);
writeln('всего ошибок: ',count)
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота