:написать программу, которая определяет, является ли введенное слово палиндромом ("перевертышем"), например: "шалаш", "арозаупаланалапуазора", и выводит на экран ответ "да" или "нет".
Program aaa; var s,s1:string; i:longint; begin writeln('введите строку'); read(s); for i:=1 to length(s) do s1:=s[i]+s1; if s=s1 then writeln('да') else writeln('нет') end.
Немного другое решение var s : string; i, j, n : integer; f : boolean; begin readln(s); n := length(s); i := 1; j := n; f := false; while (i <= j) do begin if(s[i] = s[j]) then f := true else f := false; i := i + 1; j := j - 1; if not f then break; end; if f then write('Палиндром') else write('Не палиндром'); end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку