денисвеликий
04.03.2023 08:56

Составить программу, в паскале, нахождения суммы цифр четырехзначного числа

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Апрепр
25.05.2020 16:47

var

  a: 1000..9999; //Четырехзначное число

  a1, a2, a3, a4: 1..9;

 

begin 

  writeln('Введите четырехзначное число');

  readln(a);

  a1:= a mod 10;  //Первая с конца цифра

  a2:= (a mod 100) div 10;  //Вторая с конца цифра

  a3:= (a mod 1000) div 100;  //Третья с конца цифра

  a4:= a div 1000;  //Четвертая с конца цифра

  writeln('Сумма цифр данного числа:  ', a1 + a2 + a3 + a4);  //Сумма цифр

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота