kristinamilobog
23.04.2021 02:55

Дано натуральное число. написать программу, которая определит является ли число двузначным. ответ: true или false и является ли четной сумма его цифр. 50 .​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
валя20063
25.05.2020 16:45

Python:

a = int(input())

s = 0

print("True") if len(str(a)) == 2 else print("False")

for i in str(a):

  s+=int(i)

print("сумма цифр чётная") if s % 2 == 0 else print("сумма цифр не чётная")

0,0(0 оценок)
Ответ:
Kristinkasssd001
25.05.2020 16:45
var  number: integer;begin  Readln(number);  if (number >= 10) and (number <= 99) then    begin      Writeln('True');      if (number div 10 + number mod 10) mod 2 = 0 then        Writeln('Сумма цифр чётна.')      else        Writeln('Сумма цифр нечётна.');    end  else    Writeln('False');end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота