фифа1
31.03.2022 15:23

Составьте программу, которая формирует массив из 10 случайных чисел от -15 до 15 и подсчитывает количество положительных элементов в массиве.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Маша0982
13.07.2020 15:54
Program aaa;
var
i,j,count:longint;
A:array[1..10] of longint;
begin
for i:=1 to 10 do 
  A[i]:=random(31)-15;
count:=0;
for i:=1 to 10 do 
  if A[i]>0 then  
    inc(count);
writeln(count,' положительных элементов')
end.
0,0(0 оценок)
Ответ:
imoroz079
13.07.2020 15:54
Писал с учётом очистки экрана. Тобишь модуль Uses Crt, если не проходили, то лучше удали эту строчку и "ClrScr".
Program G;
Uses Crt;
Const N=10;
Var i, count: integer; mass: array [1..N] of integer;
Begin 
 ClrSCr;
 Count:=0; 
 For i:=1 to N do
  Begin
   Mass[i]:=Random(31)-15;
   Write(Mass[i]:4);
  End;
 Writeln;
 For i:=1 to N do  
  If mass[i]>0 then inc(count);
 If count=0 then writeln('В массиве нету положительных чисел.')
  Else writeln('Количество положительных чисел в массиве: ', count);
 Readln;
 End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота