Creeper77
07.10.2022 19:07

1)в free pascal составить программу нахождения суммы цифр четырехзначного числа 2) составить программу: если существует треугольник,со сторонами a,b,c , то напечатать "да",а иначе напечатать "нет"

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
pogasii
25.05.2020 16:40

var sum, k, i: integer;


begin
readln (k);
while k > 0 do
begin
sum := sum + k mod 10; //прибавляем к сумме последнюю цифру в числе k
k := k div 10; //убираем из k эту последнюю цифру
end;
writeln(sum);
end.

 

 

 

 

 

 

var a, b, c: integer;


begin
  readln (a);
  readln (b);
  readln (c);
  if (((a + b) > c) and ((a + c) > b) and ((c + b) > a)) then //у треугольника сумма двух сторон больше третьей стороны
    writeln('да')
  else writeln ('нет');
end.

 

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота