Pascal. паскаль. написать программу, которая меняет знак всех положительных элементов, расположенных в строке и столбце матрицы с максимальным элементом
Program gt; var a:array[1..100,1..100]of integer; n,m,i,j,max,h,l:integer; begin read(n,m); max:=-maxint; for i:=1 to n do for j:=1 to m do begin read(a[i,j]); if(a[i,j]>max)then begin max:=a[i,j]; h:=i;l:=j; end; for j:=1 to m do a[h,j]:=-a[h,j]; for i:=1 to n do a[i,l]:=-a[i,l]; a[h,l]:=-a[h,l]; for i:=1 to n do begin for j:=1 to m do write(a[i,j],' '); writeln; end; end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку