Аня142
31.01.2022 07:46

Составьте программу, выясняющую, есть ли в слове х хотя бы одна из букв "о" или "а"?

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
amorfteriya
13.07.2020 07:53
Var
  s, w: string;
  i, X, n, k, p, q: integer;

begin
  Writeln('Введите фразу, разделяя слова ровно одним пробелом');
  Readln(s);
  Write('Введите номер слова для поиска: '); Readln(X);
  {
  Ищем в строке s местоположение слова номер Х.
  Его начальную позицию в строке обозначим p, а конечную - q
  }
  n := Length(s);
  i := 1; k := 0; p := 0; q := 0;
  repeat
    if s[i] = ' ' then
    begin
      Inc(k);
      if k = X - 1 then p := i + 1
      else if k = X then q := i - 1
    end;
    if q = 0 then i := i + 1
  until (q > 0) or (i > n);
  if (p = 0) then Writeln('Количество слов в строке меньше ', X)
  else if q = 0 then q := n;
  w := Copy(s, p, q - p + 1);
  if (Pos('а', w) > 0) or (Pos('о', w) > 0) then
    Writeln('Одна из букв (а,о) есть в слове "', w, '"')
  else Writeln('В слове "', w, '" нет ни буквы а, ни буквы о')
end.

Тестовое решение:
Введите фразу, разделяя слова ровно одним пробелом
Самая лучшая рыба- это колбаса!
Введите номер слова для поиска: 5
Одна из букв (а,о) есть в слове "колбаса!"

Введите фразу, разделяя слова ровно одним пробелом
Тестирование программ может служить доказательством наличия ошибок, но никогда не докажет их отсутствие!» Эд. Дейкстра, 1972 г.
Введите номер слова для поиска: 4
В слове "служить" нет ни буквы а, ни буквы о
0,0(0 оценок)
Ответ:
kamilatoktorbel
13.07.2020 07:53
#include <iostream>
#include <string>

int main()
{
std::string x;
std::cin >> x;

bool same= false;
for (auto i : x){
    if (i == 'o' || i == 'a') {same = true; break;}
}
std::cout << std::boolalpha << same;

return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота