AnnaMarkeca91
06.01.2023 06:24

Написать программу на паскаль дано натуральное число. вычислить количество цифр, являющихся степенями тройки (1,3,9).

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
SMokKK
12.07.2020 13:52
Var n, digit, ans : integer;
begin
    read(n);
    ans := 0;
    while (n > 0) do begin
        digit := n mod 10;
        if ((digit = 1) or (digit = 3) or (digit = 9)) then
            ans := ans + 1;
        n := n div 10;
    end;
    writeln(ans);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота