poshel0naher
02.05.2021 14:09

Написать программу на паскале. дано натуральное число. вычислить среднее нечетных цифр.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
svetlanakuznec5
12.07.2020 12:52
Var n, c, d, p: integer;
begin
  readln(n);
  p := 1;
  while n<>0 do begin
    d := n mod 10;
    n := n div 10;
    if d mod 2 = 1 then begin
      p := p * d;
      c := c + 1;
    end;
  end;
  
  if c = 0 then writeln (0)
  else writeln(Exp(Ln(p)/c):0:3);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота