Rombik075
04.01.2020 19:46

№1. написать программу решения уравнения вида y=2x2+0,5z uses crt; var y,x,z: real; begin clrscr; write(‘введите значения переменных x,z’); read(x,z); {ввод значений через пробел} y: = 2*x*x+0,5*z; writeln(‘результат вычислений y=’, y); end. № 2. написать программу для решения уравнения ( стандартных арифметических функции): 1.y=cos2x+sin3x 2.y=sin2π+π/2 3.y=tgx+0.25 4.y=|x|+2|z|

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
bogdOJ
12.07.2020 11:40
Задание 2, 1:
program zadacha1;
uses crt;
var x, y: real;
begin
clrscr;
write('enter x: ');
readln (x);
x:=(x*pi)/180; // в Паскале используется измерение в радианах, здесь мы
// переводим из градусов (так как мы задаем значение в градусах) в радианы
y:=sqr(cos(x))+sqr(sin(x))*sin(x);
writeln ('y=', y:0:4);
readkey;
end.

2
program zadacha2;
uses crt;
var y: real;
begin
clrscr;
y:=sqr(sin(pi))+ pi/2;
writeln ('y=', y:0:4);
readkey;
end.

3
program zadacha3;
uses crt;
var x, y: real;
begin
clrscr;
write ('enter x: ');
readln (x);
x:=(x*pi)/180;
y:=sin(x)/cos(x) + 0.25;
writeln ('y=', y:0:4);
readkey;
end.

4
program zadacha4;
uses crt;
var x, y, z: integer;
begin
clrscr;
write ('enter x, z');
readln (x, z);
y:=abs(x)+2*abs(z);
writeln ('y=', y:0:4);
readkey;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота