MalenkayaStervochka
20.12.2020 16:28

Написать программу на free pascal которая переводит число из десятичной системы в двоичную

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Kurbatovaolga15
12.07.2020 11:28
Function ToBinaryString(x: integer): string;
var r, s: string;
begin
  if x < 0 then begin
    s := '-';
    x := -x;
  end;
  while x <> 0 do begin
    r := Chr((x and 1) or 48) + r;
    x := x shr 1;
  end;

  ToBinaryString := s + r;
end;

var x: integer;
begin
  readln(x);
  writeln(ToBinaryString(x));
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота