derwi
20.12.2020 16:28

Написать программу на паскале: среди 10 целых положительных и отрицательных чисел: 1. найти максимальное и минимальное значения. 2. среднее арифметическое среди трехзначных, оканчивающихся на 1 и кратных 7.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
bogdansoroka20
12.07.2020 11:27
Var
  i, e, min, max, s, n: integer;
  c: real;

begin
  min := 32767; max := -32768; s := 0; n := 0;
  Write('Введите 10 чисел через пробел ');
  for i := 1 to 10 do
  begin
    Read(e);
    if max < e then max := e;
    if min > e then min := e;
    if (e >= 100) and (e <= 999) then
      if (i mod 10 = 1) and (i mod 7 = 0) then
      begin n := n + 1; s := s + i end
  end;
  Writeln('max=', max, ', min=', min);
  if n > 0 then Writeln('Искомое среднее равно ', s / n:0:5)
  else Writeln('Нет трехзначных чисел, оканчивающихся на 1 и кратных 7')
end.
0,0(0 оценок)
Ответ:
mashanemiro110p08m38
12.07.2020 11:27
Program  aliona;
const n=10;
var a :array[1..n] of inreger;
min,max,i:integer;
begin
randomize;
for i :=1 to n do
begin
a[i]:=random(100)+1;
write(' ',a[i]);
end;
min:=a[1];
for i:=1 to n do 
if a[i]<a[1] then a[i]:=min;
max:=a[1];
for i :=1 to n do 
if a[i]>a[1] then max:=a[i];
writeln('min=',min,'max=',max);
readln;
end,
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота