pervushina245
08.06.2022 15:35

Напишите программу,которая получает два целых числа и находит их произведение не используя операцию умножения. учтите, что числа могут быть отрицательными.пример : введите два числа: 10-15,10*(-15)=-150

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Flash017
12.07.2020 09:13
Var  a, b, prod, i: integer;
begin
  writeln('Введите два числа: ');
  readln(a, b);
  prod := 0;
  if (b < 0) then
    for i := b to -1 do
      dec(prod, a)
  else
    for i := 1 to b do
      inc(prod, a);
  writeln(prod)
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота