annakot3
04.04.2020 17:18

Составьте программу разложения данного натурального числа на простые множители. например, 200 = 2^3 × 5^2 × это умножить

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
айфон66666
02.10.2020 01:59

var

 n, i, k: integer;

begin

 repeat

   write('Введите натуральное число n= ');

   read(n);

 until n > 0;

 if n = 1 then writeln('Невозможно разложить на произведение простых множителей.')

 else

 begin

   write(n, '=');

   i := 2;

   while i <= n do

   begin

     k := 0;

     while n mod i = 0 do

     begin

       k := k + 1;

       n := n div i;

     end;

     if i < n then

     begin

       if k = 1 then write(i, '*')

       else if k > 1 then write(i, '^', k, '*');

     end

     else

     begin

       if k = 1 then write(i)

       else if k > 1 then write(i, '^', k);

     end;

     i := i + 1;

   end;

 end;

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота