yanakuznetsova9
22.10.2021 12:35

Составьте программу вычисления суммы факториалов всех чётных чисел от m до n.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Danika02
02.10.2020 01:59

var

 m, n, i: integer;  

 sum: real;

function fact(x: integer): real;

begin

 if x = 0 then fact := 1  

 else fact := fact(x - 1) * x;  

end;

begin

 writeln('Введите границы m и n соответственно : ');

 readln(m, n);  

 sum := 0;  

 for i := m to n do if not odd(i) then  

 sum := sum + fact(i);

 writeln('Сумма факториалов четных чисел последовательности = ', sum);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота