seryogasaprikin
02.02.2023 06:07

Составить программу вычисления произведения не нулевых элементов массива (а) вещественных чисел [1..5]

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
кек946
25.05.2020 14:15

var 

  a: array [1..5] of real; //Массив из пяти вещественных элементов

  i: integer; //Переменная для цикла

  s: real; //Значение произведения

 

begin

  s:= 1;

  for i:= 1 to 5 do //Вводим элементы массива

  begin

    writeln('Введите ', i, ' элемент массива');

    readln(a[i]);

    if a[i] <> 0 then s:= s * a[i]; {Если элемент массива не равен 0, то умножаем значение произведения на элемент массива}

  end;

  writeln('Произведение не нулевых элементов массива:  ', s); {Выводим значение произведения}

end.

   

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота