Onik2002
21.11.2022 01:48

Написать программку на c/c++/pascal/basic в сером королевстве запрещены все цвета. жители королевства могут использовать только варианты серого цвета от черного до белого. если рассмотреть цвет с использованием модели rgb, где каждый из трех каналов принимает значение от 0 до 255, то в сером королевстве разрешены только цвета, у которых разница между значениями в любой паре каналов не превышает 25.напишите программу, которая определяет для цвета, заданного в модели rgb, является ли он разрешенным в сером королевстве.первая строка ввода содержит три целых числа в диапазоне от 0 до 255 — значения в каналах r, g и b.вывести сообщение allowed, если цвет является разрешенным в сером королевстве, иначе выведите сообщение forbidden. пример ввода 1: 120 145 135 пример вывода 1: allowed пример ввода 2: 100 140 135 пример вывода 2: forbidden

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
darabajkova4770
14.06.2019 04:20
Program z1;   var     a, b, c: byte;   begin     writeln;     read(a, b, c);     if (abs(a-b)< 25) and (abs(b-c)< 25) and (abs(c-a)< 25) then       write('allowed')     else       write('forbidden');   end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота