polinaandreeva9
29.12.2020 21:00

Pascalabc. составьте программу рисования ряда треугольников с использованием процедуры triangle.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Elka6677
25.05.2020 13:27

uses GraphABC;

var

 i, tmp: integer;

procedure Triangle(x, y, x2, y2, x3, y3: integer);

begin

 line(x, y, x2, y2);

 line(x2, y2, x3, y3);

 line(x3, y3, x, y);

end;

begin

 SetWindowSize(600, 300);

 for i := 0 to 5 do

 begin

   tmp := i * 100;

   Triangle(0 + tmp, 200, 50 + tmo, 100, 100 + tmp, 200);

 end;

end.

0,0(0 оценок)
Ответ:
Настя15022000
16.01.2024 21:32
Конечно, я могу помочь с этим вопросом!

Прежде всего, давайте создадим процедуру triangle, которая будет рисовать треугольник. Вот как это можно сделать на языке программирования PascalABC:

program DrawTriangles;

uses crt;

procedure Triangle(n: integer);
var
i, j: integer;
begin
// Внешний цикл отвечает за количество строк
for i := 1 to n do
begin
// Внутренний цикл отвечает за количество символов в строке
for j := 1 to i do
write('*');
writeln;
end;
end;

begin
Triangle(5); // Вызываем процедуру triangle с параметром 5
readln;
end.

Давайте разберемся, как работает данная программа.

Мы создаем процедуру triangle, которая имеет один параметр - n (количество треугольников). Внутри процедуры у нас есть два цикла – внешний и внутренний. Внешний цикл выводит строки, а внутренний цикл рисует символы в каждой строке. Увеличение количества символов в строке происходит по мере прохождения внешнего цикла.

Мы вызываем процедуру triangle и передаем значение 5 в качестве параметра. Это означает, что программа будет рисовать пять треугольников.

Теперь давайте рассмотрим, как будут выглядеть треугольники, которые нарисует данная программа:

*
**
***
****
*****

В данном случае, количество строк в каждом треугольнике соответствует числу, переданному в процедуру triangle.

Если тебе нужно нарисовать другое количество треугольников, ты можешь изменить значение в вызове процедуры triangle.

Надеюсь, это помогло! Если у тебя возникнут еще вопросы, не стесняйся задавать!
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота