ПолинаКот197
03.12.2022 22:47

Составьте программу вычисления количества трехзначных чисел, у которых цифры строго по возрастанию .

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
morvilous77
10.07.2020 16:52
Var
a1,a2,a3,i,n:integer;
a:array[1..10]of integer;
begin

writeln('Ввод трехзначных чисел');
for i:=1 to 10 do
readln(a[i]);
for i:=1 to 10 do begin 
a1:= a[i] div 100; 
a2:= (a[i] div 10 )mod 10; 
a3:=a[i] mod 10;
 if (a1 < a2) and (a2 < a3) then 
  n += 1;
end;
writeln(n);  
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота