vladavlada60
20.07.2021 06:59

Дано целое число. написать программу, которая заменяет его на 0, если число отрицательное, и выводит его без изменений, в противном случае.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
kanamariya021
10.07.2020 15:19
Вот такая программа (для PascalABC.NET). И еще ты не сказал, что делать с числом, если оно равно 0?

var a,x:integer;
begin
read(a);
if a<0 then x:=0 else x:=a;
writeln(x);
end.

Не забудь откомпилировать перед проверкой.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота