nata121114
30.06.2021 11:58

Напишите программу, которая сортирует массив целых чисел и определяет количество различных значений в нём.пример: массив: 5 3 4 2 1 6 3 2 4 после сортировки: 1 2 2 3 3 4 4 5 6 различных чисел: 5

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
olik29
04.12.2021 14:35
var h1,m1,n,d,p,h2,m2: integer;
begin
  write('начало занятий (часы, минуты): ');  readln(h1,m1);
  write('количество уроков: ');  readln(n);
  write('длительность уроков: ');  readln(d);
  write('длительность перемен: ');  readln(p);
  m2:=m1+n*d+(n-1)*p;
  h2:=h1+m2 div 60;
  m2:=m2 mod 60;
  writeln('время окончания занятий: ',h2,' часов   ',m2,' минут');
end.

начало занятий (часы, минуты): 9 30
количество уроков: 4
длительность уроков: 45
длительность перемен: 10
время окончания занятий: 13 часов   0 минут
0,0(0 оценок)
Ответ:
papuh
19.02.2023 19:46
Первое задание:

program cube;
    var a,s,v:real;
begin;
    write('Введите длину ребра куба: ');
    read(a);
    v:=power(a,3);
    s:=6*sqr(a);
    write('Площадь равна ',s,', а объём равен ',v,'.');
end.

Второе задание:

program par;
    var a,b,c,s,v:real;
begin;
    write('Введите стороны a,b,c: ');
    read(a,b,c);
    v:=a*b*c;
    s:=2*(a*b+b*c+a*c);
    write('Площадь равна ',s,', а объём равен ',v,'.');
end.

Третье и четвёртое задания:

program mult;
    var r,a,b,c:real;
begin;
    write('Введите три числа: ');
    read(a,b,c);
    r:=a*b*c;
    write('Произведение чисел равно ',r);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота