marinamarina24
15.02.2020 03:06

Написать программу которая находит сумму цифр числа паскаль ( ну или хотя бы идейку подкиньте)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
schabuneva
10.07.2020 09:30
Program summa;
var a,x:integer; 
i,s:integer;
begin 
writeln('введите целое число');
 readln( a );
 x:=a; 
s:=0; 
while ( x<>0 ) do  begin   s := s + (x mod 10); 
  x := x div 10; 
end;
writeln( 'Сумма цифр числа ',a,' = ', s );
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота