Напишите программу, которая в зависимости от введенного возраста добавляет слова «год», «года» или «лет». например, при вводе возраста 1, программа сообщает «1 год», при числе 2 – «2 года», при числе 125 – «125 лет».
Var age:integer; begin readln(age); if ((age mod 100 >= 10) and (age mod 100 <= 19)) then writeln(age, ' лет') else if (age mod 10 = 1) then writeln(age, ' год') else if ((age mod 10 >= 2) and (age mod 10 <= 4)) then writeln(age, ' года') else writeln(age, ' лет'); end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку