kolya1pokachalov
29.12.2020 11:53

Program primer_1; var v,a,b,c,r,h: real; var num: integer; begin writeln('введите значение num'); writeln('num='); readln(num); case num of 1: writeln('введите значения a,b,c'); write('a='); readln(a); write('b='); readln(b); write('c='); readln(c); v: =a*b*c; writeln('v=',v: 8: 3); 2: write('bвежите значения r'); write('r='); readln(r); v: =4/3*pi*power(r; 3); writeln('v=',v: 8: 3); 3: write('введите значения r,h'); write('r='); readln(r); write('h='); readln(h); v: =1/3*pi*sqr(r)*h; wrireln('v=',v: 8: 3); else write(‘введено число вне диапазона 1-3! ’); end. пытаюсь написать программу в которой от того какую цифру из трех ты выберешь будет зависеть объем какой из трех фигур надо будет найти. вижу что ошибка в использовании оператора case, как будто нельзя писать какие-то другие действия кроме write после 1: 2: 3:

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
sashkaaaxo
10.07.2020 06:54
Кажется понял в чем проблема.У вас не работало т,к, отсутствовали begin и end; в case .Плюс еще пару недочетов в коде
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота