olgakoryakina
15.02.2021 20:11

По паскалю! введите три числа a, b, с. определите количество положительных чисел в данном наборе

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Динара010
09.07.2020 20:14
Var
  a, b, c: real;
  n: integer;

begin
  Write('Введите через пробел три числа: ');
  Readln(a, b, c);
  if a > 0 then n := 1 else n := 0;
  if b > 0 then n := n + 1;
  if c > 0 then n := n + 1;
  Writeln('Положительных чисел- ', n)
end.

Тестовое решение:
Введите через пробел три числа: -3.54 2.16 4
Положительных чисел- 2
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота