daryaevis
08.02.2021 04:08

Введено число от 1 до 1000 включительно. написать программу, с которой можно найти сумму цифр числа, введенного пользователем. писать на с++

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
nybito1
09.07.2020 14:29
#include <iostream>
using namespace std;
int n;
int sum_digits(int n)
{
  int res = 0;
  while (n > 0)
  {
    res += n % 10;
    n /= 10;
  }
  return res;
}
int main()
{
  cin >> n;
  cout << sum_digits(n);
  return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота