nikita2429p09umg
18.02.2020 05:50

Составить алгоритм и написать программу для решение с использованием двумерных массивов и конструкций цикла в цикле: вычислить сумму положительных элементов матрицы а (10х10), расположенных над главной диагональю. индекс номера строки i изменяется от 1 до 9, а индекс номера столбца j изменяется от –i+1 до 10.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
марета5
09.07.2020 12:57
Var a:array[1..10,1..10] of integer;
i,j,sum,np: integer;
begin
for i:=1 to 10 do 
 for j:=1 to 10 do readln(a[i,j]);
sum:=0;
for np:=1 to 9 do begin
 i:=np; 
 for j:=1 to np do begin 
  if a[i,j]>0 then sum:=sum+a[i,j]; 
  i:=i-1; 
 end;
end; 
writeln('Сумма элементов, расположенных выше главной диагонали равна ',sum);
readln
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота