debnatkh
24.12.2022 14:46

Pascal abc 1 составить программу которая запрашивает целое число не равное нулю сообщает положительное они или отрицательное и при этом положительное число уменьшает в 2 раза, отрицательные возводит в квадрат . 2 составить программу , которая определяет является ли введенное число нечетным и выводит на экран сообщение да или нет .

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Irina1357
09.07.2020 12:43
Первая программа ,если не нравится исправлю
Добавил вторую
0,0(0 оценок)
Ответ:
anastasiya2905
09.07.2020 12:43
1.
Program ZADACHA;
Uses crt;

var a: integer;

Begin clrscr;
      write('Введите целое число не равное нулю a = ');
      readln(a);
      writeln;
      if a<0 then
      Write('Число a отрицательное, результат = ', a*a)
     
      else
      Write('Число a положительное, результат = ', a/2);

End.

2.
Program CHETNOST;
Uses crt;

var a: integer;

Begin clrscr;
      write('Введите целое число a = ');
      readln(a);
      writeln;
      if (a mod 2) = 1 then
      Write('Да')
      else
      Write('Нет');

End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота