vladrake
25.10.2020 17:07

Написать программу для нахождения суммы цифр, составляющих число произвольной длины. написать программу, позволяющую определить, сколько заданных символов в данной фразе (искомые символы и фраза вводятся с клавиатуры. например, сколько букв а и а в слове абракадабра)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ЛСПоля
09.07.2020 10:25
Пункт а:

Насколько я помню, в паскале невозможно реализовать бесконечный цикл, поэтому решение будет слегка притянуто за уши. Например если вы введете число из 9001 символа, программа будет работать неккоректно. Для выхода из цикла используется 'метка'.

a, counter, Summa : integer;
Label Transfer;
Begin
writeln('Введите число');
readln(a);
counter := 1;
counterTw0 := counterTwo + 1;
while counter < 9000 Do
    begin
    counter := counter +1;
    if (a div counter) < 0 then Transfer
    else counterTwo := counterTwo + 1;
    else;
Goto Transfer;

//Узнали, что в числе counterTwo символов

while counter < counterTwo Do
Summa := Summa + ((a div counter) mod 10);

Summa := Summa + (a mod 10);
writeln(Summa);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота