lusine20041904
27.09.2020 13:53

Язык с ! кучу ! составить программу, которая по формулам для арифметической прогрессии находит сумму n первых элементов прогрессии и значения трех элементов с номерами (n–1), n и (n+1). число n, первый элемент и разность прогрессии вводятся пользователем. вывести значения элементов в форме таблицы, где первая строка – номер, а вторая – значение.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Kfhjrhnf
09.07.2020 06:58
#include "stdafx.h"
#include "windows.h"
#include "locale.h"

int main(){
setlocale(0, "");
int n, a1, d, sum, A1, A2, an;
printf("Введите первый элемент прогрессии  \n");
scanf_s("%i", &a1);
printf("Введите число элементов геометрической прогрессии \n");
scanf_s("%i", &n);
printf("Введите разность арифметической прогрессии \n");
scanf_s("%i", &d);
sum = ((2 * a1 + d*(n - 1)) / 2)*n;
an = a1 + d*(n - 1);
A1 = an - d;
A2 = an + d;
printf("Номер      An-1   An   An+1   sum \n");
printf("Значение   %i      %i    %i    %i \n", A1, an, A2, sum);
system("pause");
return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота