daaler
24.06.2022 04:33

Написать программу для суммирования четных элементов на нечетных позициях в одноименном массиве

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
alina1427
08.07.2020 23:04
Const
  n = 30;

var
  a: array[1..n] of integer;
  i, s: integer;

begin
  Randomize;
  Writeln('Исходный массив');
  s := 0;
  for i := 1 to n do
  begin
    a[i] := Random(101) - 50;
    Write(a[i], ' ');
    if ((i mod 2) = 1) and ((a[i] mod 2) = 0) then s := s + a[i]
  end;
  Writeln(#13#10, 'Сумма найденных элементов ', s)
end.

Тестовое решение:
Исходный массив
49 -39 -17 6 24 38 20 50 6 -36 -4 -7 -31 41 -8 20 32 49 -48 -47 50 48 -41 -44 -26 -11 9 38 -24 -34
Сумма найденных элементов 22
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота