DmdmdmA
06.04.2023 18:45

Вариант 5. для контроля. комплеит ладаний, 1. написать программу расчета по формуле. предварительно подготовить тестовые примеры. + 2. написать программу, попадание точки с определенными координатами в заданную плоскую область. значения координат и радиуса вводить с клавиатуры. работы программы вывести в виде текстового сообщения 3. разработать программу обработки одномерного массива вещественных величин. размерность массива задать именованной константой. 1) найти минимальный элемент массива 2) найти сүмму элементов массива, расположенных между перным и последним положительными элементами. 3) преобразовать массива так, чтобы сначала располагались все элементы, равные нулю, потом - все остальные. 4. разработать программу обработки двумерного массива. дана целочисленная прямоугольная матрица. определить: 1 )составить программу подсчета суммы всех отрицательных элементов и суммы элементов главной диагонали; 2) вывести на экран только элементы всех четных строк матрицы. вывод организовать по строкам. 5. разработать программу обработии текстового файла с использованием строк и символов. написать программу, которая создает/открывает файл address. txt и дописывает в него фамилию, имя, город проживания, введенные с консоли. необходимо ввести не менее 5 записей. организовать поиск в файле городу, найти всех, проживающих в городе определенном городе и вывести информацию о них 6. описать структуру с заданным именем и полями. разработать программу, обрабатывающую массив таких структур указанным коллекция книголюба. поля: шифр книги, автор, название, год издания, местоположение (номер стеллажа). написать программу, которая выбирает необходимую информацию с диска и выводит на экран: - местоположение книги, автора х названия - список книг автора z, находящихся в коллекции; - число книг издания хх года, имеющихся в библиктеке. 7. выполнить 3, 4 используя подходящие контейнеры и алгоритмы. 8. выполнить 1, 2, 5 каждый пунит в виде функции. все необходимые данные для функций должны передаваться им в качестве параметров. использование переменных в функциях не допускается. 9. выполнить 3, 4 оформив каждый пункт в виде шаблона функции. все необходимые данные для функций должны передаваться им в качестве параметров. использование переменных в функциях не допускается. примеры программ, использующих эти шаблоны для типов int, float и double. 10. разработать оконное приложенине для windows с применением технологии win api, демонстрирующее результаты 1, 2.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
milenairk38
24.11.2020 09:37
1. Разностная машина Беббиджа должна была заменить группу вычислителей, которые аккуратно склвдывали и вычитали числа. Поэтому утверждение "Б" - справедливо
2. Подготовка данных с перфокарт, утверждение "А" - справедливо.
3. Утверждение "Г" - спорно, хотя в 2000 году в лондонском Музее науки заработал принтер, придуманный Бэббиджем для своей машины.

Вообще машина проектировалась как механический аппарат предназначенный для автоматизации вычислений путем аппроксимации функций многочленами и вычисления конечных разностей.
0,0(0 оценок)
Ответ:
wwwOli6578000
14.07.2022 00:45
//Pascal ABC.NET v3.1 сборка 1172

Const
 n=5;

Var
 ma:array[1..n,1..n] of integer;
 i,j,max,maxj,a:integer;
begin
max:=-1;
randomize;
 writeln('Matrix:');
  for i:=1 to n do
   begin;
   for j:=1 to n do
    begin;
     ma[i,j]:=random(10);
     write(ma[i,j]:4);
    end;
   writeln;
   end;
  for j:=1 to n do
  begin
   for i:=1 to n do
     a:=a+ma[i,j];
   if a>max then
    begin
     max:=a;
     maxj:=j;
    end;
    a:=0;
  end;
write('Максимальный по сумме столбец:',maxj);
end.

Пример работы кода:
Matrix:
   8   6   8   0   2
   6   1   2   9   8
   8   1   8   0   1
   4   5   1   5   2
   3   0   9   9   5
Максимальный по сумме столбец:1
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота