BearSlesher
06.04.2023 07:11

Надо. написать программу с цикла, которая позволяет ввести с клавиатуры последовательность из трех дробных чисел и после ввода каждого числа выводит среднее арифметическое полученной части последовательности. ниже представлен рекомендуемый вид экрана во время работы программы: *обработка последовательности дробных чисел* после ввода каждого числа нажмите - > 12.3 введено чисел: 1 среднее арифметическое: 12.30 - > 15 введено чисел: 2 среднее арифметическое: 13.65 - > 10 введено чисел: 3 среднее арифметическое: 12.43

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:

var a: array[1..3] of real;

x: real;
i: shortint;
begin
writeln('После ввода каждого числа нажмите <Enter>');
a[1]:=0; a[2]:=0; a[3]:=0;
for i:=1 to 3 do begin
write('->');
readln(a[i]);
x := ((a[1]+a[2]+a[3])/i)*100;
x := round(x);
x := x/100;
writeln('Введено чисел: ',i,' Среднее арифметическое: ',x);
end;
end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота