nata1116
17.02.2021 05:22

Программа паскальвводится число от 1 до 100 с точностью до сотых долей поменять местами дробные и целые части.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
romapotseluiko
27.10.2021 11:43

using System;

namespace Dvumerni_Случайные_числа

{

   class Program

   {

       static void Main(string[] args)

       {

           //Случайный размер массива от 5 до 10 элементов

           Random Value = new Random();

           int RazmerMassiva = Value.Next(5,10);  

           //Объявление массива с случайным размером элементов

           int[] Massiv_1 = new int [RazmerMassiva];

           //Заносим случайные значения в массив от 1 до 5

           Random RandomCifr = new Random();

           for (int i = 0; i < Massiv_1.GetLength(0); i++)

               Massiv_1[i] = RandomCifr.Next(1,5);

           //Обьявление переменных чтобы работать в цикле "While"

           int proverochka = 0;

           int schetchikIndekca = 0;

           /*Обьявление нового массива (Massiv_2),который будет по размеру таким же как размер массива "Massiv_1"  

           И будет принимать его значения увеличенные на 15 в цикле "While" */

           int[] Massiv_2 = new int[Massiv_1.Length];

           //Увеличиваем значения в Massiv_1 на 15 и заносим их в Massiv_2

           while (Massiv_1.Length > proverochka)

           {

               Massiv_2[schetchikIndekca] = Massiv_1[schetchikIndekca] + 15;

               proverochka++;

               schetchikIndekca++;

           }

           //Выводим новый массив (Massiv_2) в консоль чтобы посмотреть как отработала программа

           foreach (var item in Massiv_2)

                Console.WriteLine(item);

       }

   }

}

Объяснение: Программа выполнена в C#. Не было указано на каком языке нужно выполнять.


Напишите программу,которая создает массив,заполняет его случ-ми числами и к каждому элементу массива
Напишите программу,которая создает массив,заполняет его случ-ми числами и к каждому элементу массива
0,0(0 оценок)
Ответ:
саша23310
15.12.2022 20:43

a) (z >= -7) and (z <= 10);

б) (x mod 2 = 0);

в) (x <> 78);

г) (x mod 2 <> 0);

Ошибки в программе:

1) Переменная а объявлена как integer, т.е предназначена для хранения целочисленных значений. Но при этом в программе ей присваивают значение 4.13, которое не является целым числом.

Правильно будет объявить переменную а типа real;

2) После ключевого слова begin никогда не ставится точка с запятой;

3) Перед else не ставится точка с запятой;

4) После заключительного end требуется ставить точку.

Правильный вариант:

var

 a:real;

begin

 a:=4.13;

 if (a+1 > 7) then write('a = ', a*3) else

   write('a = ', a*6);

end.


Запишите на языке Паскаль следующие условия. Только условия! а) z ϵ [-7; 10]; б) x четное число; в)
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота