malaya108
21.06.2021 11:53

Написать программу на pascal. вычислить произведение множества значений функции y= 2*a+7 / 3*a-2 при изменяющихся a 6, 7, 7 .. 18.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
nuk890
08.07.2020 12:17

program znanija_com_task_32583491;

var proizv:real;

   i:integer;

function y(a:integer):real;

        begin

             y:=(2*a+7)/(3*a-2)

        end; {function y}

begin

    proizv:=y(6)*y(7);

    for i:=7 to 18 do

    begin

         proizv:=proizv*y(i);

    end; {for i}

    write('proizvedenie mnozhestva znachenij funkcii y = ',proizv)

end.

{

Как я понял задание, во-первых, функция это дробь с числителем 2a+7, а знаменатель 3а-2. Если всё-таки дробный коэффициент перед вторым слагаемым это легко меняется в теле функции.

Также, мне кажется, что счетчик цикла 7..18 - это 1. То есть, только функция от натурального аргуента. В принципе тоже легко меняется уже в главной программе.

А дальше уже произведение рассчет самого главного: y(6) * y(7) * y(7) * y(8) * ... * y(16).

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота