vadimsheglov0
09.05.2021 08:36

Составить программу которая находит количество натуральных чисел которые не делятся ни на одно из чисел 2,7,11

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
йцуячс2
08.07.2020 08:52
var
  s, k, err: integer;
  str: string;
begin
  writeln('Введённая пустая строка (без каких-либо символов) считается концом последовательности и, собственно, завершает выполнение программы, как бы говоря ей: "Эй, подруга! Выведи-ка количество чисел, не делящихся ни на два, ни на семь, ни на одиннадцать!"');
  while (true) do
  begin
    readln(str);
    val(str, k, err);
    if (err > 0) then break;
    if ((k mod 2 = 0) and (k mod 7 = 0) and (k mod 11 = 0)) then
      inc(s);
  end;
  writeln(s);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота