nastyr17
18.07.2020 23:54

Пусть задана последовательность чисел a, b, c, d. составить программу вычисления количества k положительных чисел, содержащихся в этой последовательности. печатать a, b, c, d, k.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
olga810706
08.07.2020 08:29
Var
  a,b,c,d,K:integer;
begin
  write('Введите a,b,c,d: ');
  readln(a,b,c,d);
  K:=0;
  if a>0 then K:=K+1;
  if b>0 then K:=K+1;
  if c>0 then K:=K+1;
  if d>0 then K:=K+1;
  writeln(a,' ',b,' ',c,' ',d,' K=',K);
end.

Тестовое решение:

Введите a,b,c,d: -4 5 3 0
-4 5 3 0 K=2
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота