Сделать на pascalabc, попросили сделать с записей. составить программу, которая вводит данные о студентах: № п/п, фамилию, год рождения, пол, курс, вид спорта и выводит: выводит данные только о спортсменках по курсам и спорта в алфавитном порядке.
const n=3; type student=record fam:string[20]; year:integer; sex:string[1]; kurs:integer; sport:string[30]; end; var x:array[1..n] of student; i,j:integer; p:student; begin for i:=1 to n do with x[i] do begin writeln('сведенья о ',i,' студенте:'); writeln('фамилия: '); read(fam); writeln('год рождения: '); read(year); writeln('пол( м или ж ): '); read(sex); writeln('курс: '); read(kurs); writeln('вид спорта: '); read(sport); end;
for i:=1 to n-1 do for j:=i+1 to n do if x[i].fam>x[j].fam then begin p:=x[i]; x[i]:=x[j]; x[j]:=p; end; for i:=1 to n do begin with x[i] do if (sex='ж') then writeln('Фамилия студентки: ',fam,' Курс: ',kurs,' Вид спорта: ',sport); end; end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку