katrinzeta18
24.09.2021 09:43

Написать программу в паскале: опишите множество pr(1..20) и поместите в него все простые числа в диапозоне 1..20. в цикле организуйте ввод чисел в диапозоне 1..20 и определите, простые они или нет . выход из цикла - введеное значение , равное 99.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
slaider1123
01.10.2020 22:58
Var
  Pr: set of 1..20;
  x: integer;

begin
  Pr := [1, 2, 3, 5, 7, 11, 13, 17, 19];
  writeln('Вводите целые числа от 1 до 20, выход по 99');
  repeat
    write('Число ');
    readln(x);
    if x < 21 then
      if x in Pr then writeln('простое')
      else writeln('не простое')
  until x = 99
end.

Тестовое решение:

Вводите целые числа от 1 до 20, выход по 99
Число 18
не простое
Число 3
простое
Число 15
не простое
Число 23
Число 19
простое
Число 99
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота