Slash213
27.05.2020 10:42

Составьте программу, определяющую принадлежность точки а(х, у) окружности с центром 0(0; 0) и радиусом r. в паскалеabc.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
егор1481
01.10.2020 22:53
Var x,y,r:real;
begin
writeln('Введите радиус окружности');
readln(r);
writeln('Введите координаты точки А');
readln(x,y);
if sqr(x)+sqr(y)=sqr(r) then writeln('Принадлежит')
else writeln('Не принадлежит');
end.
0,0(0 оценок)
Ответ:
Dag18y5557hvvhi
01.10.2020 22:53
Var x,y,r:real;
begin
readln(r);
readln(x,y);
    if sqr(x)+sqr(y)<=sqr(r) then
        writeln('принадлежит')else writeln('не принадлежит');
end.
в предыдущем решении точка лежит только на границе окружности
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота