marekatyan
10.01.2023 21:42

Составить программу! надо ракета запускается с земли со скоростью v(км час) в направлении движения земли по орбите вокруг солнца. составить программу,определяющую результат запуска ракета в зависимости от скорости v. известно,что при v16,4 ракета покинет солнечную систему.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
elmariya
01.10.2020 22:52
Решение на VB

Sub Rocket()
    Dim x As Single
    x = InputBox("Введите скорость ракеты в км/с")
    Select Case x
    Case Is < 7.91
        MsgBox "Ракета упадет на Землю"
    Case 7.91
        MsgBox "Ракета будет вращаться вокруг Земли по круговой орбите"
    Case Is < 11.2
        MsgBox "Ракета будет вращаться вокруг Земли по эллиптической орбите"
    Case Is < 16.4
        MsgBox "Ракета будет перемещаться в пределах Солнечной системы"
    Case Else
        MsgBox "Ракета покинет Солнечную систему"
    End Select
End Sub
0,0(0 оценок)
Ответ:
Лейла1994
01.10.2020 22:52
Var v:real;
begin
write('Введите скорость в км/c: ');
readln(v);
if v<7.9 then
  writeln('Ракета упадет на Землю');
if v=7.9 then
  writeln('Ракета будет двигаться вокруг Земли по круговой орбите');
if (v>7.9) and (v<11.2) then
  writeln('Ракета будет двигаться вокруг Земли по эллиптической орбите');
if v=11.2 then
  writeln('Ракета будет двигаться вокруг Солнца по круговой орбите');
if (v>11.2) and (v<16.4) then
  writeln('Ракета будет двигаться вокруг Солнца по эллиптической орбите');
if v>16.4 then writeln('Ракета покинет Солнечную систему');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота